DNS Resolution Issues
Affected components
Updates

Resolved

Traffic levels have normalised and both nameservers are now stable.
A full post-incident report will be published.

Wed, Nov 26, 2025, 12:24 PM

Monitoring

Filtering has been deployed to suppress abnormal traffic patterns.
NS2 performance is improving and we are monitoring closely.

Wed, Nov 26, 2025, 10:47 AM(1 hour earlier)

Identified

To stabilise DNS services, we have taken NS2 offline to increase compute capacity.
DNS resolution remains available via NS1.

Wed, Nov 26, 2025, 09:46 AM(1 hour earlier)

Identified

The elevated request load on NS2 is increasing and causing intermittent DNS failures.
We are exploring both scaling options and traffic filtering to stabilise the nameserver.

NS1 continues to operate normally.

Wed, Nov 26, 2025, 09:20 AM(26 minutes earlier)

Investigating

We have confirmed that NS2 is experiencing degraded performance, resulting in slow or failed DNS responses for domains using that nameserver.
All other services remain operational.

We are investigating the cause of the degraded performance and assessing next steps.

Wed, Nov 26, 2025, 08:33 AM(47 minutes earlier)

Investigating

We are continuing to investigate the root cause.
Early signs suggest the issue is isolated to NS2, while NS1 remains fully operational.

We are reviewing traffic patterns and system performance on NS2.

Wed, Nov 26, 2025, 08:20 AM(12 minutes earlier)

Investigating

Our monitoring has detected intermittent DNS resolution failures affecting a number of domains.
This appears to be affecting some queries made via our secondary nameserver (NS2).

We are investigating and will update within 30 minutes.

Wed, Nov 26, 2025, 07:54 AM(25 minutes earlier)
Powered by
© Blake Mark Productions Ltd, 2025 All Rights Reserved | Company No. 15804012 | Registered at: 124 City Road, London, United Kingdom, EC1V 2NX.