Intermittent connection issues
Affected components
Updates

Resolved

All services are working as expected - an RFO will be published in due-course.

Thank you for your patience during this time.

Thu, Oct 30, 2025, 05:32 PM

Monitoring

We have identified the root cause and deployed a fix. The service is currently stable and under active monitoring. We’ll provide another update once we are confident the issue has been fully resolved.

Thu, Oct 30, 2025, 10:24 AM(7 hours earlier)

Monitoring

We have identified the root cause and deployed a fix. The service is currently stable and under active monitoring. We’ll provide another update once we are confident the issue has been fully resolved.

Thu, Oct 30, 2025, 02:39 AM(7 hours earlier)

Investigating

We’re seeing intermittent connection failures and timeouts across parts of our infrastructure.

We are investigating as quickly as possible and will provide an update shortly.

Thu, Oct 30, 2025, 01:39 AM(59 minutes earlier)
Powered by
© Blake Mark Productions Ltd, 2025 All Rights Reserved | Company No. 15804012 | Registered at: 124 City Road, London, United Kingdom, EC1V 2NX.